3 new sunsun 704b with priming issue

Discussion about tank equipment (lights, heaters, etc.) & books. Also DIY projects.

Moderator: Ken Boorman

Post Reply
kuait
Posts: 1
Joined: Thu Aug 29, 2019 12:05 pm

3 new sunsun 704b with priming issue

Post by kuait » Thu Aug 29, 2019 12:17 pm

Hello everyone and looking for help

I have recently pushed 3 Sunsun 704b and shipped to my country within 30 days, fine at least I receive them.

the issue here that I need your help pls as following

1. All three canisters 220-240v 50z, in my country the voltage is 220 60z
2. the problem, it has been almost eight days trying to make them work but no luck

I am trying to set up my new sunsun 704b. I have primed and primed, but this thing won't work for almost eight days until now. It will water stay on for a minute or so, and then it just quits pulling water into the hose. The intake hose is fill up but does not continue pulling. I have read everything I can find online, and I can't find a solution. Anybody here knows what I can do? Please help! i am stuck

FYI: I have contacted the Ubuy.com, but it looks they do not have a solution, and it will cost me a lot to return the products

Bullet
Posts: 2
Joined: Sun Jan 26, 2020 6:09 pm

Re: 3 new sunsun 704b with priming issue

Post by Bullet » Sat Apr 25, 2020 2:10 pm

I don't know this might be stupid but I have two different canister filters that I have to while they're running tip them on their side numerous times to get them Prime to where they will actually get the air out of the canister no matter how full you fill it that it seemed to work for me.

Post Reply

Return to “Equipment, Supplies, Books and DIY”